21 May 2020

qemu vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 20.04 LTS
  • Ubuntu 19.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

Several security issues were fixed in QEMU.

Software Description

  • qemu – Machine emulator and virtualizer

Details

It was discovered that QEMU incorrectly handled bochs-display devices. A
local attacker in a guest could use this to cause a denial of service or
possibly execute arbitrary code in the host. This issue only affected
Ubuntu 19.10. (CVE-2019-15034)

It was discovered that QEMU incorrectly handled memory during certain VNC
operations. A remote attacker could possibly use this issue to cause QEMU
to consume resources, resulting in a denial of service. This issue only
affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.10.
(CVE-2019-20382)

It was discovered that QEMU incorrectly generated QEMU Pointer
Authentication signatures on ARM. A local attacker could possibly use this
issue to bypass PAuth. This issue only affected Ubuntu 19.10.
(CVE-2020-10702)

Ziming Zhang discovered that QEMU incorrectly handled ATI VGA emulation. A
local attacker in a guest could use this issue to cause QEMU to crash,
resulting in a denial of service. This issue only affected Ubuntu 20.04
LTS. (CVE-2020-11869)

Aviv Sasson discovered that QEMU incorrectly handled Slirp networking. A
remote attacker could use this issue to cause QEMU to crash, resulting in a
denial of service, or possibly execute arbitrary code. This issue only
affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.10.
(CVE-2020-1983)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 20.04 LTS
qemu1:4.2-3ubuntu6.1
qemu-system1:4.2-3ubuntu6.1
qemu-system-arm1:4.2-3ubuntu6.1
qemu-system-mips1:4.2-3ubuntu6.1
qemu-system-ppc1:4.2-3ubuntu6.1
qemu-system-s390x1:4.2-3ubuntu6.1
qemu-system-sparc1:4.2-3ubuntu6.1
qemu-system-x861:4.2-3ubuntu6.1
Ubuntu 19.10
qemu1:4.0+dfsg-0ubuntu9.6
qemu-system1:4.0+dfsg-0ubuntu9.6
qemu-system-arm1:4.0+dfsg-0ubuntu9.6
qemu-system-mips1:4.0+dfsg-0ubuntu9.6
qemu-system-ppc1:4.0+dfsg-0ubuntu9.6
qemu-system-s390x1:4.0+dfsg-0ubuntu9.6
qemu-system-sparc1:4.0+dfsg-0ubuntu9.6
qemu-system-x861:4.0+dfsg-0ubuntu9.6
Ubuntu 18.04 LTS
qemu1:2.11+dfsg-1ubuntu7.26
qemu-system1:2.11+dfsg-1ubuntu7.26
qemu-system-arm1:2.11+dfsg-1ubuntu7.26
qemu-system-mips1:2.11+dfsg-1ubuntu7.26
qemu-system-ppc1:2.11+dfsg-1ubuntu7.26
qemu-system-s390x1:2.11+dfsg-1ubuntu7.26
qemu-system-sparc1:2.11+dfsg-1ubuntu7.26
qemu-system-x861:2.11+dfsg-1ubuntu7.26
Ubuntu 16.04 LTS
qemu1:2.5+dfsg-5ubuntu10.44
qemu-system1:2.5+dfsg-5ubuntu10.44
qemu-system-aarch641:2.5+dfsg-5ubuntu10.44
qemu-system-arm1:2.5+dfsg-5ubuntu10.44
qemu-system-mips1:2.5+dfsg-5ubuntu10.44
qemu-system-ppc1:2.5+dfsg-5ubuntu10.44
qemu-system-s390x1:2.5+dfsg-5ubuntu10.44
qemu-system-sparc1:2.5+dfsg-5ubuntu10.44
qemu-system-x861:2.5+dfsg-5ubuntu10.44

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart all QEMU virtual
machines to make all the necessary changes.

References



Source link

Write a comment:
*

Your email address will not be published.