10 February 2020

libxml2 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.10
  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 ESM
  • Ubuntu 12.04 ESM

Summary

Several security issues were fixed in libxml2.

Software Description

  • libxml2 – GNOME XML library

Details

It was discovered that libxml2 incorrectly handled certain XML files.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2019-19956, CVE-2020-7595)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
libxml22.9.4+dfsg1-7ubuntu3.1
libxml2-utils2.9.4+dfsg1-7ubuntu3.1
Ubuntu 18.04 LTS
libxml22.9.4+dfsg1-6.1ubuntu1.3
libxml2-utils2.9.4+dfsg1-6.1ubuntu1.3
Ubuntu 16.04 LTS
libxml22.9.3+dfsg1-1ubuntu0.7
libxml2-utils2.9.3+dfsg1-1ubuntu0.7
Ubuntu 14.04 ESM
libxml2 – 2.9.1+dfsg1-3ubuntu4.13+esm1
libxml2-utils – 2.9.1+dfsg1-3ubuntu4.13+esm1
Ubuntu 12.04 ESM
libxml2 – 2.7.8.dfsg-5.1ubuntu4.22
libxml2-utils – 2.7.8.dfsg-5.1ubuntu4.22

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References



Source link

Write a comment:
*

Your email address will not be published.