This security advisory describes one high risk vulnerability.

1) Code Injection

Severity: High

CVSSv3:
8.6 [CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-9408

CWE-ID:
CWE-94 – Improper Control of Generation of Code (‘Code Injection’)

Description


The vulnerability allows a remote attacker to execute arbitrary code on the target system.


The vulnerability exists due to improper input validation in the Spotfire library component. A remote authenticated attacker can modify attributes of files and objects saved to the library such that the system treats them as trusted and execute arbitrary code on the target system.


Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

TIBCO Spotfire for AWS:
-, 10.8.0

TIBCO Spotfire Server:
7.0.0, 7.0.1, 7.0.2, 7.5.0, 7.5.1, 7.6.0, 7.6.1, 7.7.0, 7.7.1, 7.8.0, 7.8.1, 7.8.2, 7.9.0, 7.9.1, 7.10.0, 7.10.1, 7.10.2, 7.11.0, 7.11.1, 7.11.2, 7.11.3, 7.11.4, 7.11.5, 7.11.6, 7.11.7, 7.11.8, 7.11.9, 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.0.1, 10.1.0, 10.2.0, 10.3.0, 10.3.1, 10.3.2, 10.3.3, 10.3.4, 10.3.5, 10.3.6, 10.4.0, 10.5.0, 10.6.0, 10.6.1, 10.7.0, 10.8.0

CPE
External links

http://www.tibco.com/services/support/advisories
https://www.tibco.com/support/advisories/2020/03/tibco-security-advisory-march-11-2020-tibco-spotfire-server

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.





Source link

You must be logged in to post a comment.