2) Use-after-free

Severity: Low

CVSSv3:
8.1 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:U/RC:C] [PCI]

CVE-ID:
CVE-2020-1712

CWE-ID:
CWE-416 – Use After Free

Description

The vulnerability allows a local user to escalate privileges on the system.

The vulnerability exists due to a use-after-free error when processing dbus messages during asynchronous Polkit queries in bus-polkit.c in systemd. A local unprivileged user can send a specially crafted dbus message, trigger a use-after-free error and crash services or execute arbitrary code on the system with elevated privileges.

Mitigation

Update the affected packages.

Vulnerable software versions

Opensuse:
15.1

CPE
External links

https://lists.opensuse.org/opensuse-security-announce/2020-02/msg00014.html

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.





Source link

Write a comment:
*

Your email address will not be published.