Risk Medium
Patch available YES
Number of vulnerabilities 5
CVE ID CVE-2020-25627
CVE-2020-25628
CVE-2020-25629
CVE-2020-25630
CVE-2020-25631
CWE ID CWE-79
CWE-285
CWE-264
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Moodle

Web applications /
Other software
Vendor moodle.org

Security Advisory

1) Stored cross-site scripting

Risk: Low

CVSSv3:
4.7 [CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-25627

CWE-ID:
CWE-79 – Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’)

Exploit availability:
No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via moodlenetprofile user profile field. A remote user can inject and execute arbitrary HTML and script code in user’s browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Moodle:
3.9.0, 3.9.1

CPE

External links

https://moodle.org/mod/forum/discuss.php?d=410839

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Cross-site scripting

Risk: Low

CVSSv3:
5.3 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-25628

CWE-ID:
CWE-79 – Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’)

Exploit availability:
No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed to the filter in the admin task log. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user’s browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Moodle:
3.0, 3.0.0, 3.0.0-beta, 3.0.0-rc1, 3.0.0-rc2, 3.0.0-rc3, 3.0.0-rc4, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.1.0, 3.1.0-beta, 3.1.0-rc1, 3.1.0-rc2, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.2.0, 3.2.0-beta, 3.2.0-rc1, 3.2.0-rc2, 3.2.0-rc3, 3.2.0-rc4, 3.2.0-rc5, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.3, 3.3.0, 3.3.0-beta, 3.3.0-rc1, 3.3.0-rc2, 3.3.0-rc3, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8, 3.3.9, 3.4.0, 3.4.0-beta, 3.4.0-rc1, 3.4.0-rc2, 3.4.0-rc3, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9, 3.5.0, 3.5.0-beta, 3.5.0-rc1, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.6.0, 3.6.0-beta, 3.6.0-rc1, 3.6.0-rc2, 3.6.0-rc3, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.6.10, 3.7.0, 3.7.0-beta, 3.7.0-rc1, 3.7.0-rc2, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.8.0, 3.8.0-beta, 3.8.0-rc1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.1

CPE

External links

https://moodle.org/mod/forum/discuss.php?d=410840

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Improper Authorization

Risk: Medium

CVSSv3:
4.7 [CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-25629

CWE-ID:
CWE-285 – Improper Authorization

Exploit availability:
No

Description

The vulnerability allows a remote user to escalate privileges within the application.

The vulnerability exists due to an error within the “Log in as” feature. A remote user with “Log in as” capability in a course context (typically, course managers) can gain access to some site administration capabilities by “logging in as” a System manager.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Moodle:
3.0, 3.0.0, 3.0.0-beta, 3.0.0-rc1, 3.0.0-rc2, 3.0.0-rc3, 3.0.0-rc4, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.1.0, 3.1.0-beta, 3.1.0-rc1, 3.1.0-rc2, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.2.0, 3.2.0-beta, 3.2.0-rc1, 3.2.0-rc2, 3.2.0-rc3, 3.2.0-rc4, 3.2.0-rc5, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.3, 3.3.0, 3.3.0-beta, 3.3.0-rc1, 3.3.0-rc2, 3.3.0-rc3, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8, 3.3.9, 3.4.0, 3.4.0-beta, 3.4.0-rc1, 3.4.0-rc2, 3.4.0-rc3, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9, 3.5.0, 3.5.0-beta, 3.5.0-rc1, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.6.0, 3.6.0-beta, 3.6.0-rc1, 3.6.0-rc2, 3.6.0-rc3, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.6.10, 3.7.0, 3.7.0-beta, 3.7.0-rc1, 3.7.0-rc2, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.8.0, 3.8.0-beta, 3.8.0-rc1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.1

CPE

External links

https://moodle.org/mod/forum/discuss.php?d=410841

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Permissions, Privileges, and Access Controls

Risk: Low

CVSSv3:
3.8 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L/E:U/RL:O/RC:C]

CVE-ID:
CVE-2020-25630

CWE-ID:
CWE-264 – Permissions, Privileges, and Access Controls

Exploit availability:
No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to the decompressed size of zip files is
not checked against available user quota before unzipping them in the file picker unzip functionality. A remote
attacker trick the victim to unzip a large archive and perform a denial of service (DoS) attack.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Moodle:
3.0, 3.0.0, 3.0.0-beta, 3.0.0-rc1, 3.0.0-rc2, 3.0.0-rc3, 3.0.0-rc4, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.1.0, 3.1.0-beta, 3.1.0-rc1, 3.1.0-rc2, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.18, 3.2.0, 3.2.0-beta, 3.2.0-rc1, 3.2.0-rc2, 3.2.0-rc3, 3.2.0-rc4, 3.2.0-rc5, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.3, 3.3.0, 3.3.0-beta, 3.3.0-rc1, 3.3.0-rc2, 3.3.0-rc3, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8, 3.3.9, 3.4.0, 3.4.0-beta, 3.4.0-rc1, 3.4.0-rc2, 3.4.0-rc3, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 3.4.9, 3.5.0, 3.5.0-beta, 3.5.0-rc1, 3.5.1, 3.5.2, 3.5.3, 3.5.4, 3.5.5, 3.5.6, 3.5.7, 3.5.8, 3.5.9, 3.5.10, 3.5.11, 3.5.12, 3.5.13, 3.6.0, 3.6.0-beta, 3.6.0-rc1, 3.6.0-rc2, 3.6.0-rc3, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.6.9, 3.6.10, 3.7.0, 3.7.0-beta, 3.7.0-rc1, 3.7.0-rc2, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.8.0, 3.8.0-beta, 3.8.0-rc1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.1

CPE

External links

https://moodle.org/mod/forum/discuss.php?d=410842

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

5) Cross-site scripting

Risk: Low

CVSSv3:
4.7 [CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-25631

CWE-ID:
CWE-79 – Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’)

Exploit availability:
No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data passed via a book’s chapter title. A remote attacker can inject and execute arbitrary HTML and script code in user’s browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Moodle:
3.7.0, 3.7.0-beta, 3.7.0-rc1, 3.7.0-rc2, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.7.6, 3.7.7, 3.8.0, 3.8.0-beta, 3.8.0-rc1, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.1

CPE

External links

https://moodle.org/mod/forum/discuss.php?d=410843

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote authenticated user via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.





Source link

You must be logged in to post a comment.