1) Improper Handling of Exceptional Conditions

Severity: Low

CVSSv3:
5.7 [CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-12888

CWE-ID:

Exploit availability:
No

Description


The vulnerability allows a local user to perform a deinal of service (DoS) attack.


The vulnerability exists due to the VFIO PCI driver mishandles attempts to access disabled memory space. A local user can cause a denial of service condition on the target system.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Linux kernel:
5.6, 5.6.1, 5.6.2, 5.6.3, 5.6.4, 5.6.5, 5.6.6, 5.6.7, 5.6.8, 5.6.9, 5.6.10, 5.6.11, 5.6.12, 5.6.13

CPE

External links

http://www.openwall.com/lists/oss-security/2020/05/19/6
https://lore.kernel.org/kvm/158871401328.15589.17598154478222071285.stgit@gimli.home/
https://lore.kernel.org/kvm/158871570274.15589.10563806532874116326.stgit@gimli.home/

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Out-of-bounds read

Severity: Medium

CVSSv3:
5.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-13143

CWE-ID:
CWE-125 – Out-of-bounds Read

Exploit availability:
No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to a boundary condition in “gadget_dev_desc_UDC_store” in “drivers/usb/gadget/configfs.c” file. A remote attacker can trigger out-of-bounds read error and cause a denial of service on the target system.

Mitigation

Install updates from vendor’s website.

Vulnerable software versions

Linux kernel:
5.6, 5.6.1, 5.6.2, 5.6.3, 5.6.4, 5.6.5, 5.6.6, 5.6.7, 5.6.8, 5.6.9, 5.6.10, 5.6.11, 5.6.12, 5.6.13

CPE

External links

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=15753588bcd4bbffae1cca33c8ced5722477fe1f
https://www.spinics.net/lists/linux-usb/msg194331.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.





Source link

Write a comment:
*

Your email address will not be published.