1) Buffer overflow

Severity: High

CVSSv3:
8.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-8174

CWE-ID:
CWE-119 – Improper Restriction of Operations within the Bounds of a Memory Buffer

Exploit availability:
No

Description

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error within napi_get_value_string_latin1(), napi_get_value_string_utf8(), or napi_get_value_string_utf16() functions. A remote attacker can create a specially crafted data to the application, trigger memory corruption and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Mitigation

Update nodejs package to version 10.21.0~dfsg-1~deb10u1.

Vulnerable software versions

nodejs (Debian package):
10.0.0~dfsg-1, 10.0.0~dfsg-2, 10.0.0~dfsg1-3, 10.0.0~dfsg1-4, 10.1.0~dfsg-1, 10.3.0~dfsg-1, 10.4.0~dfsg-1, 10.12.0~dfsg-1, 10.13.0~dfsg-1, 10.13.0~dfsg-3, 10.15.0~dfsg-1, 10.15.0~dfsg-2, 10.15.0~dfsg-4, 10.15.0~dfsg-5, 10.15.0~dfsg-6, 10.15.0~dfsg-7, 10.15.0~dfsg-8, 10.15.0~dfsg-9, 10.15.0~dfsg-10, 10.15.1~dfsg-1, 10.15.1~dfsg-2, 10.15.1~dfsg-3, 10.15.1~dfsg-4, 10.15.1~dfsg-5, 10.15.2~dfsg, 10.15.2~dfsg-1, 10.15.2~dfsg-2, 10.15.3~dfsg, 10.15.3~dfsg-1, 10.16.3~dfsg-1, 10.17.0~dfsg-1, 10.17.0~dfsg-2, 10.19.0~dfsg, 10.19.0~dfsg-1, 10.19.0~dfsg-2, 10.19.0~dfsg-3, 10.19.0~dfsg1-1, 10.20.0~dfsg-1, 10.20.1~dfsg, 10.20.1~dfsg-1

CPE

External links

https://www.debian.org/security/2020/dsa-4696

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Resource exhaustion

Severity: Medium

CVSSv3:
6.5 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID:
CVE-2020-11080

CWE-ID:
CWE-400 – Uncontrolled Resource Consumption (‘Resource Exhaustion’)

Exploit availability:
No

Description

The vulnerability allows a remote attacker to perform a denial of service (DoS) attack.

The vulnerability exists due to application does not properly control consumption of internal resources when processing HTTP/2 SETTINGS frames. A remote attacker can trigger high CPU load by sending large HTTP/2 SETTINGS frames and perform a denial of service (DoS) attack.

Mitigation

Update nodejs package to version 10.21.0~dfsg-1~deb10u1.

Vulnerable software versions

nodejs (Debian package):
10.0.0~dfsg-1, 10.0.0~dfsg-2, 10.0.0~dfsg1-3, 10.0.0~dfsg1-4, 10.1.0~dfsg-1, 10.3.0~dfsg-1, 10.4.0~dfsg-1, 10.12.0~dfsg-1, 10.13.0~dfsg-1, 10.13.0~dfsg-3, 10.15.0~dfsg-1, 10.15.0~dfsg-2, 10.15.0~dfsg-4, 10.15.0~dfsg-5, 10.15.0~dfsg-6, 10.15.0~dfsg-7, 10.15.0~dfsg-8, 10.15.0~dfsg-9, 10.15.0~dfsg-10, 10.15.1~dfsg-1, 10.15.1~dfsg-2, 10.15.1~dfsg-3, 10.15.1~dfsg-4, 10.15.1~dfsg-5, 10.15.2~dfsg, 10.15.2~dfsg-1, 10.15.2~dfsg-2, 10.15.3~dfsg, 10.15.3~dfsg-1, 10.16.3~dfsg-1, 10.17.0~dfsg-1, 10.17.0~dfsg-2, 10.19.0~dfsg, 10.19.0~dfsg-1, 10.19.0~dfsg-2, 10.19.0~dfsg-3, 10.19.0~dfsg1-1, 10.20.0~dfsg-1, 10.20.1~dfsg, 10.20.1~dfsg-1

CPE

External links

https://www.debian.org/security/2020/dsa-4696

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.





Source link

Write a comment:
*

Your email address will not be published.