Reported: 2020-02-24 06:09 UTC by Ted (Jong Seok) Won
Modified: 2020-02-24 11:05 UTC
(History)
79
users

(show)


Fixed In Version:

tomcat 9.0.31, tomcat 8.5.51, tomcat 7.0.100

Doc Type:

If docs needed, set a value

Doc Text:

CVE-2020-1938 is a file read/inclusion vulnerability in the AJP connector in Apache Tomcat. This is enabled by default with a default configuration port of 8009. A remote, unauthenticated attacker could exploit this vulnerability to read web application files from a vulnerable server. In instances where the vulnerable server allows file uploads, an attacker could upload malicious JavaServer Pages (JSP) code within a variety of file types and trigger this vulnerability to gain remote code execution (RCE).

It was fixed in Apache Tomcat 9 before version 9.0.31, Tomcat 8 before version 8.5.51, and Tomcat 7 before version 7.0.100.

Clone Of:

Environment:

Last Closed:



Source link

Write a comment:
*

Your email address will not be published.